Yield Engine currently supports Corn, Soybeans, Wheat, Barley, Peanuts, and Cotton. Any other crops are considered unsupported by Yield Engine. If you have an unsupported crop, Yield Engine will provide a “Not Available for [specific crop]” message. If the crop type is incorrect for the field, please visit Field Story to edit the existing planting event. 

Did this answer your question?